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I love pixels! They’re the building blocks of all the visual design we do 
here at ustwo™, but are so often relegated to a mere afterthought in 
the excitement of working with colours and styles. The aim of this Pixel 
Perfect Precision™ handbook is to bring them back to the forefront of 
our thoughts, to make sure we get the simple things right before 
moving onto the detail.

Why is this important though? Isn’t it just wasting time worrying about 
every last pixel on the page? Like a lot of things in life, when 
something’s done right it should become invisible to you, but when it’s 
done badly it becomes an annoyance. Blurred edges, objects that jump 
in position between pages, and colour mismatches are just a few things 
that a user will notice and become distracted by if your designs aren’t 
done properly, leaving them with a poor impression of the product.

This handbook originally started with just two or three pages on how to 
set up colour profiles (still the first chapter), but with time I’ve added 
pretty much everything I’ve learnt in the form of instructions, guidance 
and tips. From junior designer to creative director there’s usually 
something to pick up and learn in here!

Gyppsy xx

Introduction
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Colour Profiles 



System Settings To avoid any nasty colour jumps between 
Photoshop and Mac OS X the colour settings 
need to be set up correctly. First thing to do is 
make sure System Preferences > Displays > 
Color is set to the device you are currently 
using (for laptops this is Color LCD).
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Photoshop Colour 
Settings

Next, in Photoshop, go to Edit > Colour 
Settings… and change Working Spaces > RGB 
to the screen specified in your System 
Preferences. Also change Color Management 
Policies > RGB to Off.
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Photoshop Save for 
Web

Additionally, in Save for Web the Convert to 
sRGB option needs to be deselected, and 
Preview should be set to Monitor Color. Colours 
should now be consistent on your machine!
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Pixel Precision



Naughty Nice

Sharp Edges Straight edges should be on-pixel and sharp - 
blurred edges are a no-no!
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Snapping Photoshop has lots of handy tools to help get 
those edges sharp. The first thing to do is 
enable snapping - go to View > Snap and make 
sure it’s on. Snapping helps with pixel precision 
and also alignment (discussed later on).

The Snap To submenu shows the various items 
that Photoshop can use for snapping.
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Shape Layer 
Options

We love Shape Layers here. They’re easy to 
use and manipulate, don’t slow down 
Photoshop as much as Smart Objects, and 
help to keep file sizes down. Winner. In 
Photoshop CS5 Rectangles and Rounded 
Rectangles have a built in option to aid pixel 

precision: Snap to Pixels. To access this option 
click the drop-down menu to the right of the 
shapes in the top tool bar. This needs to be 
selected for both Rectangle and Rounded 
Rectangle individually as their options are 
independent of each other.
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Snap to Pixel Grid With Photoshop CS6 there is a global option to 
snap vectors to pixels in the Preferences - 
make sure Snap Vector Tools and Transforms to 
Pixel Grid is selected (it’s on by default). Much 
easier knowing that every Shape Layer you 
draw will automatically be pixel precise!

10ustwo™ studios 2013  /  PPP™



Grids Sometimes it’s useful to have a grid on screen 
when creating a layout. The example above is 
using 10px gridlines with 10 subdivisions, 
which makes it easy to count pixel dimensions 
and stops the grid from becoming visually 
overpowering when used. 

Go to Photoshop > Preferences > Guides, Grid, & 
Slices… to set yours up.
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Nudging If you’re using Photoshop CS5 be careful when 
using the keyboard to shift points of a Shape 
Layer when zoomed into a design - the nudge 
amount varies according to the zoom factor. 
To guarantee a 1px nudge, zoom out to 100% 
and press the arrow key once. If zoomed in at 

200% and the arrow key is pressed the points 
will only move 0.5px (i.e. half the amount), 
creating blurred edges - not good. With CS6 
pixel grid snapping the points will move 1px no 
matter what level the zoom is; you’ll need to 
switch off the snap to move by smaller 
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Alignment & 
Spacing

Once you’ve mastered the art of getting 
everything sharp the next step in your journey 
towards pixel perfection is to get the 
alignment and spacing right.
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Multiple objects on a page should all have 
some sort of alignment: left, right, centred etc. 
Also, if there are repetitions of a similar object 
across the screen then the spacing should be 
consistent between each one.

The Layer > Align and Layer > Distribute menus 
make it easy peasy to quickly tidy up objects.
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Alignment of objects across multiple screens is 
just as important. Margins and placement of 
common items such as titles, tabs and footers 
should be the same throughout the interface 
to prevent objects jumping around.

The basic layouts above show a consistent use 
of margins and spacing. In reality a UI would 
probably not be this simplistic (if it is then 
you’re laughing), however there should still be 
some form of underlying grid to define the 
structure.
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GuideGuide To help automate the creation of guides 
there’s a free Photoshop Extension available 
called GuideGuide; once installed it can be 
found in the Window > Extensions menu. By 
varying the data you enter it can work out 
measurements such as column and gutter 

widths, or if you’ve already sussed these out 
on a scrap of paper you can just input all the 
values and get your guides inserted 
automatically. There are tooltips for each of 
the input box icons to let you know what each 
one does.
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Text Height & 
Width

A great way to check the maximum height 
that a block of text can be is to use the Åy 
characters. If a design needs to fit a minimum 
number of characters then use a series of 
capital Ws to judge the space needed - if they 
fit then anything else will too.
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Settings
Einstellungen
Configurações

Text Length If you’re working on a design that will be used 
with other languages it’s also worth 
considering how long your text could be when 
translated. The example above shows what 
happens with the German and Portuguese 

translations of Settings: an increase of up to 
75% in length.
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Align Text

Align Text Align Text

Align Text

Aligning Text with 
Objects

Try to vertically align text using the x-height, 
ignoring ascenders and descenders. This 
means that dynamic text, which could contain 
any combination of characters, will always 
look correctly aligned.
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Aligning Text on 
Buttons

Featured above are three ways to vertically 
aligning text on buttons. There are a few 
variables which can affect which method is 
the best, such as the typeface used (for 
example the cap height to x-height ratio can 
vary) or whether you’re using upper- and 

lowercase text or caps/numbers. The most 
important thing though is to make sure that 
once you pick a rule you use it on every button 
- consistency is king!
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Global Light Default 
Angle

This is one of those little things that 
Photoshop will catch you out on if you’re not 
careful. If you’ve set up a design with a 
custom Global Light direction, then drag an 
element from it to a new document, it will 
take on the default 120° instead. As you can 

see in the images above this can mess up the 
design. To help prevent this from happening 
too often you can change the default to a 
more commonly used angle like 90°. Close all 
files in Photoshop and go to the Layer > Layer 
Style > Global Light… to alter the default value.
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Info Panel As well as using the measurement readout 
when drawing vector shapes or using the 
marquee tool to get some super pixel 
precision, there is also the Info Panel for extra 
detail. Not only does it show measurements 
but it can also display colour and opacity 

values that will allow you to quickly check 
consistency throughout a design.
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Techniques



Shape Layers As mentioned in the previous chapter use 
Shape Layers wherever possible. Being vector-
based they’re more editable than bitmaps 
allowing transformation of the shape with no 
loss in quality, and are less resource hungry 
than Smart Objects.
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Shape Layer 
Backgrounds

By using unmasked Shape Layers for 
backgrounds instead of bitmaps the fill will 
automatically scale if the canvas size is 
increased. Nice.
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Transformations Another advantage of Shape Layers is that 
transformations such as resize and rotate 
render better than with Smart Objects - their 
edges can go a little jagged when distorted 
from the original dimensions. 

The difference in the examples is quite subtle, 
but in other objects it will be more obvious.
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Complex Vectors For complex vectors the best solution is to use 
Illustrator then copy and paste into Photoshop 
(using Shape Layers). Outline any strokes in 
the Illustrator original, otherwise they won’t 
import to Photoshop properly. Remember by 
reciting this phrase to yourself: “Don’t be a 

joke, outline the stroke”. If the vector is more 
than just a shape, for example a full colour 
Windows style icon, then it will have to be 
pasted as a Smart Object.
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Pasting From 
Illustrator

One quirk of pasting in a Shape Layer from 
Illustrator is that it sometimes shifts the 
object off-centre by 0.5px in either or both 
axes, resulting in blurred pixels (although with 
the new CS6 pixel snapping options this seems 
to be less of an issue now). Always have a 

quick look to see if this has happened, and if it 
has shift the shape back by half a pixel to its 
intended position.
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Layer Effects Another thing we love here are Layer Effects, 
so we try to create as much styling as possible 
using them. The effects are completely 
editable, can be scaled in ratio to their 
underlying shapes, and can be quickly copied 
and pasted to other objects.
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Concise Layer 
Effects

Try not to spread Layer Effects across different 
layers, it’s much better if they’re all on one if 
possible - keeps things tidy and makes it 
easier to copy styles around between objects.
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Object Colours It’s a good idea with Shape Layers and text to 
change the colour using the object’s own 
setting instead of the Color Overlay Layer 
Effect. The benefits of this are a) it’s quicker to 
update the colour later on as there’s no need 
to load up the Layer Effects window, and b) it 

will make finding the object easier in the 
Layers palette. As an example: in which panel 
above is the blue square easier to find?
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Object Gradients The same thing applies to gradients - use a 
gradient fill layer instead of Layer Effects if 
possible. With Photoshop CS5 the big 
advantage over Layer Effects is that there’s a 
Dither option, which increases the quality of 

the gradient when spread over large areas. In 
CS6 you can dither both.
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Colour Model HSB FTW! Have a go at using HSB in the Color 
Picker to create a palette, once you get your 
head around it you’ll see it’s a really efficient 
way to create shades of a base colour. In the 
example the Hue (H) value has been kept the 
same, then the Saturation (S) and Brightness 

(B) changed to create the variations. See how 
much more sense the numbers make in HSB 
compared to RGB as well?
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H 16 16 16 16

S 100 50 25 50

B 100 100 100 50

R 255 255 255 127

G 67 161 208 81

B 0 127 191 64



Blending Modes When creating effects remember to only use 
blending modes on items which will later be 
merged with other layers. In the example the 
highlight layer will be exported as a separate 
asset, but when shown on its own the 

blending effect disappears and it becomes a 
solid white to black gradient.
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Nice

The best solution is to recreate the effect 
using a layer that is independent of what is 
beneath it.
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Replacement text

The original line of text

Text Alignment When adding text make things easier for 
yourself in the future by matching the 
paragraph alignment to that in the design, so 
text that is supposed to look left aligned has 
this setting as well. If you then have to change 
the text it will still have the correct alignment.
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Paragraphs If you’ve got a paragraph of text then use a 
text box instead of manually adding line 
breaks as they all have to be reset when text is 
changed or the typeface altered. With a text 
box though the text will wrap automatically, 
and the paragraph can easily be resized. Yay!
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Convert to 
Paragraph Text

Fortunately Photoshop gives you the option to 
convert between freeform and boxed text, and 
vice versa, by selecting Type > Convert to 
Paragraph Text or Convert to Point Text. For 
Photoshop CS5 these functions are found in 
the Layer > Type > menu.
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Hyphenation Most devices don’t support hyphenation so 
you might as well switch it off.
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Leading When adding paragraphs of text Photoshop 
will default to an automatic amount of 
leading, which is usually a bit too tight. Make 
your text easier to read by manually changing 
this amount - in the example the leading has 
been changed from (Auto) to 18pt.
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Lists In some cases when creating lists, particularly 
those with graphics next to them, it’s better to 
put all the descriptions into one single text 
object and set the leading to match the item 
spacing, rather than using separate layers for 

each one. This makes it easier to align and 
space everything correctly.
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Text Anti-aliasing There are a few different types of anti-aliasing 
in Photoshop which can be used to get the 
best legibility from text - play around with the 
settings to find the most suitable one.

For mockups of text on a device have a look 
through the various methods and see which 
one is closest to how it appears on-screen.
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Touch Affordance The screens on mobile devices often have a 
higher pixel resolution (PPI) than that of a 
typical computer display, so you need to make 
sure you don’t create buttons and text that 
are too small to use. 

As a rough rule zoom out to 50% to see the 
size of things in real life, if they’re too small 
make ‘em bigger!

43ustwo™ studios 2013  /  PPP™



Screen Resolution Have a look a phone-size.com for details on 
phone sizes and screen resolutions. You can 
then set up your Photoshop document with 
the correct PPI and reduce some of the trial 
and error with text and button sizes.
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Accessibility
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Colour Blindness

ProtanopiaDeuteranopia

Around 8-10% of the male population have 
some form of colour blindness, so don’t forget 
to consider these users when creating your 
designs! Shown above are examples of how 
the different types of colour blindness affect a 
user’s perception of the colour spectrum. 

Deuteranopia, the most common form, relates 
to the green receptors in the eye and makes it 
harder to distinguish between reds and 
greens. Similarly, protanopia has an effect on 
the red receptors; since the red and green 
receptors are quite close to each other in 
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Tritanopia

terms of what colours they perceive there is 
some overlap in the impacted areas of the 
spectrum. Tritanopia is the rarest form of 
colour blindness, and affects the blue 
receptors in the eye. For more information visit 
We are Colorblind.

Colour Blindness
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Previewing in 
Photoshop

Tucked away in the View > Proof Setup menu 
are a couple of options to preview how your 
design will look to people with the common 
forms of colour blindness - this is a great way 
to quickly see if there are any issues with 
colours and contrast.
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Sim Daltonism Sim Daltonism is a more advanced application 
for checking colour blindness accessibility 
across every variation of the condition. 
Instead of being a Photoshop only tool it can 
be used across the entire OS - the app is 
basically a resizable floating window that 

previews whatever is underneath the mouse 
cursor.
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Colour Contrast Always make sure that text and other 
important information has enough contrast 
between foreground and background to still 
be legible for those with some form of colour 
blindness. There’s a great online checker 

available here - just pop in the two colours 
and away you go!
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Techniques In some cases you might not want to adjust 
the colours you’ve chosen for a design, but still 
want to make sure that you don’t exclude 
those with colour blindness. In those cases 
think about other ways you can distinguish 
various sections from each other. Above are a 

couple of ideas: one is to use some icons, the 
other is adding a pattern to the blocks. Both 
help to separate the sections based on more 
than just the colour.
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Color Add What would you do if you wanted to describe 
colours, but didn’t want to use text labels? 
Turns out a great solution already exists: Color 
Add is a simple system that represents colours 
using symbols. By combining these symbols, 
representing the three primary colours in 

subtractive light, you can mix and match 
together to create the whole spectrum - just 
as you would with paint or ink. It’s also 
possible to represent light and dark shades by 
merging these symbols with those for white 
and black. 
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Red / 
Magenta Yellow White Black
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There’s lots more information on their site, 
including some great colouring pencils for 
colour blind people!

Color Add
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Organisation



Layers Panel 
Options

Is there anything more annoying than the 
“copy” that Photoshop adds on to every 
duplicated layer?! Remove that and some 
other visual clutter by going to the Layers 
Panel Options and switching off Use Default 
Masks on Fill Layers, Expand New Effects and 

Add “copy” to Copied Layers and Groups. Every 
little helps.
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Naming Layers Don’t be selfish, give your layers proper 
names! It makes life a lot easier for the next 
person who has to work on your files, and 
you’ll look good if the file gets sent off to a 
client.
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Ordering Layers If you really want to make your files super 
special then order the layers nicely as well. A 
logical way is to follow how the objects appear 
in the design from left to right, top to bottom, 
just like reading a book (apologies if your first 
language goes in another direction!).
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Colour Coding Here’s an example of how colour coding in the 
Layers panel can make it easier to navigate. 
Right click on the show/hide control to bring 
up the layer colour menu.
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Red (“danger”) for old 
unused elementsGrey (“neutral”) used for reference 

items that relate to the core design, 
in this case overlays which specify 

the fonts and sizes
Splash screen

Preferences window

Popups

Core design remains uncoloured

Green here to highlight two variations of a design 
which hasn’t been decided yet

Yellow here to show that hidden layers are 
different states of the same button



Expanded Layer 
Effects

Like a messy house guest, expanded Layer 
Effects can make it harder to find your way 
around. Keep them collapsed and things are a 
lot better.
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Locked Layers Locking layers is a great way to preserve an 
object when working on a file, but try to make 
sure that they’re unlocked when handing over 
to other designers. Digging through layer sets 
trying to find the rogue locked layer that’s 

preventing you from moving or deleting the 
group can get really frustrating!
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Layer Comps Layer Comps: so close, yet so far. What could 
be a great way to show multiple variations or 
layouts in a file is held back by the fact that 
changing anything once they’re set screws 
them up, so you can’t really use them whilst 

working on a design. Best created once your 
document is xxxx_final_finished_finito.psd.
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Illustrator



Introduction Illustrator: deploy when Photoshop’s vector 
tools just aren’t quite up to the task! We tend 
to use it for creating complex vectors which 
can then be styled in Photoshop - that way 
they retain their scaleability but get all the 
visual treats that Layer Effects allow too
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Illustrator Colour 
Settings

It’s worth setting up the colour profiles in 
Illustrator as well - for example you might 
want to add some colour to vector sketches 
which match what you see in Photoshop.

As with its sibling, go to Edit > Colour 
Settings…, make sure Working Spaces > RGB is 
set to the screen specified in your System 
Preferences and Color Management Policies > 
RGB is Off.
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Useful Settings There are a couple of useful settings in 
Illustrator > Preferences. The first is to set the 
Units to Pixels for General and Stroke, which 
will mean all your dimensions will match up 
pixel for pixel with Photoshop. 

Once this is done the keyboard increment can 
be set to 1px, which means the cursor keys 
can be used to nudge shapes and points 
around while remaining on whole pixel 
measurements.
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Grids Like Photoshop, the Illustrator grid can be set 
up in Illustrator > Preferences > Guides, Grid, & 
Slices…, again with 10px gridlines and 10 
subdivisions.
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Snap to Grid Yup, you guessed it, stick Snap to Grid on too! 
Like Photoshop it’s located in the View menu.
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Smart Guides Sometimes you need to push the boundaries 
and break out of the grid, in which case a good 
alternative is to use Smart Guides for non-
straight/off-grid shapes and points. In the 
example above a right-angled triangle has 
been placed below a circle; the Smart Guides 

have recognised where the two overlap and 
let you easily add a point where the two 
intersect.
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Precision The Transform window is your pixel precision 
best friend. It can either be used to check a 
whole shape (top row), or a single point 
(bottom row). Also, make use of the link 
option for the W and H boxes, so when one 
value is changed the other will also adjust by 

the same proportion, keeping the object in 
scale.
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Align to Pixel Grid The new super-villain of Illustrator! Make sure 
this option is deselected when drawing shapes 
- it will align objects on the artboard to the 
underlying grid, which can cause unexpected 
shifts in the position when strokes are added 

for example. To show the Options go to the 
Transform panel menu.
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Pixel Preview This is another one to be wary of: when View > 
Pixel Preview is on it can show pixels as being 
precise when in reality they’re not.
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Preview Blurring Nothing to worry about too much here, but 
sometimes Illustrator will show a shape as 
having blurred edges even though the 
dimensions are exact in the Transform 
window. This seems to be a bug with the 
program, but thankfully the blurring won’t 

appear when the shape is imported into 
Photoshop.
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Organisation If you tried to name every layer in an 
Illustrator file you’d get nothing else done, but 
try to organise shapes into groups so you don’t 
end up with one massive artboard the size of a 
football pitch - not fun to scroll around!
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Naming & Export



Naming Elements Coming up with a standard naming system on 
a project eases the transition from design to 
development. Most UIs have the same sort of 
features: title bars, buttons, icons, tabs, 
backgrounds etc. so it makes sense to base 
the naming on these…

Title     Btn     Icn     Tab     Bg

To distinguish between different buttons you 
could then add their location as part of the 
name…

Btn_Left     Btn_Right     Btn_Menu     Btn_Home

…or you could base it on the width/height of 
the button if they are all the same style 
perhaps…

Btn_120     Btn_180     Btn_240

Different states of an element can be added 
to that…

Btn_Home_Normal      Btn_Home_Pressed     

A similar thing also applies to icons…

Icn_Message     Icn_Inbox     Icn_Add

…which can also have their states as a suffix…

Icn_Message_Normal      Icn_Inbox_Pressed

For non-interactive elements with only one 
state there can also be some standardisation 
of the naming…

Logo      Title      Footer      Bg

Backgrounds for any section of the UI could 
use the name “bg” for instance, followed by 
their location or colour…

Bg      Bg_Menu      Bg_List      Bg_Black

The next page shows a UI and how these 
naming conventions could be applied to it.
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Naming Elements
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Tab_Share_Active

Bg_Photo

Icn_Add_Sticker

Sticker_Frame

Sticker_Glasses

Icn_Share



Asset Files Using our ustwo™ Crop & Export scripts (see 
next page) we’ve tried to make the asset 
export process super easy. The first thing to do 
is set your files up properly for them to work: 
put every individual object that you want to 
export within its own layer group and give it 

an asset name; each group can contain as 
many layers as you want as the scripts work 
on everything at the root level. Also if you lay 
everything out separately as shown, rather 
than stacked on top of each other, you’ll end 
up with a useful asset reference sheet.
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Export Scripts We’ve built some awesome Photoshop scripts 
that will run through a file and export all the 
individual assets as PNGs…no muss, no fuss. 
Just copy them from _scripts to your Adobe 
Photoshop CS5/Presets/Scripts folder, (re)start 
Photoshop and you’re good to go! There are a 
few variations:

ustwo™ Crop & Export [filename][layername]  
This will crop to each asset and then export 
the file as [filename][layername].png, so with 
a file called button.psd, and layer called 
_normal the exported asset would be called 
button_normal.png.

ustwo™ Crop & Export [layername]  
Same script as above except in this case the 
filename is not added to the exported asset, 
only the layer name is used. For the example 
above the exported asset would be called 
_normal.png.

ustwo™ Crop & Export +1px [filename]
[layername] 
In this case the exported asset will have a 1px 
margin added around each edge so that it will 

work correctly in Flash. File naming works as 
with the normal Crop & Export.

ustwo™ Crop & Export +1px [layername] 
Same as above, using the alternative naming 
method.

There are also a couple of additional scripts 
available which won’t crop the layers but will 
instead stick to the dimensions of the 
Photoshop file. This can be useful for things 
like screen comps where the actual content 
might change size, but you want all the 
exported PNGs to have the same dimensions.

ustwo™ Export [filename][layername]

ustwo™ Export [layername]
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Save for Web Check out the differences in file size of the two 
different PNGs here - Save As… has created a 
file that’s 26KB bigger than Save for Web. Well 
worth using the latter then!
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Reducing File Size Everyone’s happier when file sizes are kept 
down, so if you have an asset that doesn’t 
need transparency try converting it to an 8bit 
PNG. In the example above there’s no loss in 
quality from making the switch, but the file 
size has been almost halved.
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ImageOptim If you want to shave a few more KB from your 
exported file sizes then give ImageOptim a 
whirl - simply drag and drop your files onto its 
window and watch as it works its magic. The 
app works on PNG, JPEG and GIF images by 
stripping out any unnecessary metadata such 

as comments and colour profiles, as well as 
optimising the compression used.

As a side note if you’re developing for iOS then 
it might not be worth using ImageOptim as 
this article explains.
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Reducing 
Photoshop File Sizes

A quick way to shave some of the size from 
your PSDs is to switch off the visibility of all the 
layers. Not always practical if a design requires 
a certain combination to be shown, but it can 
be useful if sending or uploading files and you 

want to keep things small. Zipping the file 
afterwards also dramatically reduces the size.
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565 Some devices don’t support all the colours 
that you can see on your computer screen, 
which can cause visual degradation of your 
assets. To prevent this from happening convert 
them to 565 images using the Ximagic 
ColorDither SP plugin. 565 refers to the colour 

depth change from 24bit (8+8+8) to 16bit 
(5+6+5) (16.7 million to 65536 colours, a 
commonly supported amount on mobile 
screens); to counteract the reduction in 
colours the filter also applies dithering, which 
will prevent banding in any gradients.
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565 Batch The best way to apply 565 dithering to 
multiple files is to create a Photoshop Action 
and use the File > Automate > Batch tool. 
Export all the assets normally using one of the 
Crop & Export scripts, then set up an Action to 
apply the filter and export using Save for Web 

(rather than Save and Close in the Destination 
menu which will increase the file size). The 
action shown is included in _actions/PPP™.atn; 
you’ll need to create a folder called export on 
your Desktop for the processed files to be  
saved in.
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Animation



Introduction If your file is going to end up being animated 
then try to optimise it as much as possible 
using some of the tips in this section - you’ll be 
in the animator’s good books if you do!
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File Size Optimise the file size as much as possible, as 
complex files will slow down After Effects. 
Keep duplicates of layers to a minimum, and 
use Shape Layers instead of Smart Objects.

87ustwo™ studios 2013  /  PPP™

Naughty Nice



States Make sure everything’s labelled up correctly 
and there’s some sort of order to it.
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Flatten Layers Flatten any parts of the UI that won’t need 
any further changes, such as backgrounds. 
These can then be exported as PNGs and used 
in After Effects separately from the PSD file, 
which will speed things up.
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Tips



Strokes Strokes with a 1px thickness can look a little 
too thin on curved shapes (straight edges are 
fine though), so to strengthen the stroke 
without making it bigger also add a Glow 
using the settings shown. The difference is 
subtle, but it definitely helps.
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Fading Circles Circular fades are really useful for loading 
icons and can be created easily with the Stroke 
Layer Effect. The trick is to set Fill Type: 
Gradient and use Style: Angle.
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Quick Shine You can create a quick shine effect using a 
white inner shadow with a low Opacity value. 
Be careful though as the shape of the shine 
will follow that of the top edge of the layer it is 
applied to, so it tends to work best with 
rectangular or near-rectangular objects.
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Extracting Logos Sometimes it can be difficult to obtain a 
decent vector logo, in which case a last resort 
is to extract one using this process. Another 
useful tip is to search a company’s site to see 
if they have any PDF documents available for 

download: they’ll often have logos in them 
which can then be opened in Illustrator.
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Flat logo merged to a white background
Image > Adjustments > Invert
Then Select All and Copy

Image > Adjustments > Desaturate
Add a colour layer, add a layer mask, alt-click 
on the mask and then Paste. This will create 
a mask from the black and white logo image

Image > Adjustments > Levels
Use the black point picker to select 
the main grey colour

You now have a logo on a transparent 
background



Star Fields Have a play around with the settings in the 
Brushes panel to create some different brush 
effects, like a basic star field for example. By 
increasing the Size Jitter and Opacity Jitter the 
brushes become more random.

95ustwo™ studios 2013 /  PPP™



Patterns Add a little something to your designs by 
including a pattern or texture. They’re easy to 
make using the Pattern tool: first draw a tile 
that can be repeated smoothly, drag a 
selection around it, then go to Edit > Define 
Pattern… to add it to the presets. This pattern 

can then be used throughout Photoshop, 
including the Layer Effects palette. Experiment 
with Blend Modes and Opacity to alter the 
pattern’s look (black and white work well as 
they are neutral colours and will work with any 
underlying design).
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Kuler Feeling a bit uninspired when it comes to 
colours and palettes? Then give Kuler a go! It’s 
an online service where users can create and 
browse through colour palettes, but there’s 
also an extension for it so you don’t even need 
to leave Photoshop. 

It’s an incredibly useful tool for creating colour 
schemes or finding a bit of inspiration.
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Shortcuts When creating a selection hold down the 
Space key to move it around before letting go 
of the mouse button and fixing the size.

Use the square bracket keys [ and ] to adjust 
brush size up and down. Shift plus [ or ] will 
increase the brush hardness.
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Select a layer and press the forward slash / key 
to lock transparency. On Shape Layers this will 
lock the position instead.

Collapse or expand all layer sets in a 
document by holding down the Command key 
and clicking on one of the triangle icons.
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Hide all other layers by holding down Alt and 
clicking on the visibility icon. 

To show or hide layers in a row click, hold 
down and drag the cursor across all the 
relevant visibility icons.
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F (Cycle screen modes) 
Switch between normal, fullscreen with task 
bar and full screen with black background.

Space bar (Hand tool) 
Temporarily selects the hand tool while held 
down, use to pan around an image.

Command + ` (Cycle open documents) 
Acts like Alt + Tab in the OS, changing between 
open documents.

Space + F (Canvas background) 
Cycles through canvas colours.

X (Switch colours) 
Flips the foreground and background colours.

D (Default colours) 
Resets foreground and background colours to 
black and white.

Arrow keys (Move selection outline) 
Moves selection outline by 1px.

Shift + Arrow keys (Move selection outline)  
Moves selection outline by 10px.

Command + Arrow keys (Move selection)  
Moves selected layer or area by 1px.

Command + Shift + Arrow keys (Move 
selection) 
Moves selected layer or area by 10px.

Command + Option + A (Select all layers)  
Selects all layers in the layers palette.

Command  + Click layer thumbnail (Load layer 
as selection) 
Load layer transparency as a selection

Shift + Click mask (Enable/disable layer mask)  
Switch layer mask on and off.

Alt + Click mask (View mask) 
Show the layer mask as a separate image 
which can be edited like a channel.
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Command + Click mask (Load mask as 
selection) 
Loads up the mask as a selection.

Command + Shift + I (Invert selection) 
Reverse the current selection so previously 
selected areas become deselected and vice 
versa.

Command + D (Deselect) 
Removes current selection.

Command + Shift + D (Reselect) 
Reloads the last selection.

Command + J (Copy layer) 
Duplicate the currently selected layer.

1 - 0 (Change layer opacity) 
Adjust the selected layer opacity in 10% 
increments.

Shift + [+/-]  (Cycle blending modes) 
Cycle through layer blending modes.
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Keyboard Shortcuts 
and Menus

Become a Photoshop lean machine by 
creating custom keyboard shortcuts using the 
Edit > Keyboard Shortcuts… dialog. In this 
example a couple have been created for Align 
Vertical and Horizontal Centres.

Another really useful thing to do is remove the 
Command+Q shortcut to prevent any 
accidental quits of Photoshop.
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Appendix



SSStyles™ There is a library of Super Slick Styles™ to use 
as inspiration in _styles/SSStyles™.psd

THESE SHOULDN’T BE COPIED DIRECTLY AS 
THEY’RE BASED ON OTHER DESIGNS!
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PPPatterns™ There’s also a library of patterns available to 
use in _patterns/PPPattern™.pat and also 
ready applied as Layer Effects in _patterns/
PPPattern™.psd
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thank you!


